Thursday, July 9, 2009

Routing Information Protocol (RIP) Configuration.

RouterA#show ip route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, serial0/1

C 3.0.0.0/8 is directly connected, serial0/0

C 192.168.1.0/24 is directly connected, loopback0

 Configure RIP on Router A

RouterA#configure terminal

RouterA#(config)#router rip

RouterA#(config-router)#network 3.0.0.0

RouterA#(config-router)#network 1.0.0.0

RouterA#(config-router)#network 192.168.1.0

RouterA#(config-router)#exit

RouterA#(config)#

 

Now verify these configuration on router A with command us under:

RouterA#show ip route

To check the routing protocol with this command.

RouterA#show ip protocols

 

RouterB#show ip route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, serial0/1

C 2.0.0.0/8 is directly connected, serial0/0

C 192.168.1.0/24 is directly connected, loopback0

 

Configure RIP on Router B

 

RouterB#configure terminal

RouterB#(config)#router rip

RouterB#(config-router)#network 1.0.0.0

RouterB#(config-router)#network 2.0.0.0

RouterB#(config-router)#network 192.168.2.0

RouterB#(config-router)#exit

RouterB#(config)#

 

Now verify these configuration on router B with command us under:

RouterB#show ip route 

RouterC#show ip route

Gateway of last resort is not set

C 2.0.0.0/8 is directly connected, serial1

C 3.0.0.0/8 is directly connected, serial0

C 192.168.3.0/24 is directly connected, loopback0

 

Configure RIP on Router C

RouterC#configure terminal

RouterC#(config)#router rip

RouterC#(config-router)#network 2.0.0.0

RouterC#(config-router)#network 3.0.0.0

RouterC#(config-router)#network 192.168.3.0

RouterC#(config-router)#exit

RouterC#(config)#

 

Now verify these configuration on router C with command us under:

RouterC#show ip route

Break or recover the router password

  • Turn the power switch off and back on to recycle the power. 

  • Press the Break key or key sequence to put the router into ROM Monitor mode. The break key varies by computer or terminal software. The sequence might be CTRL-D, CTRL-Break or another combination.
  • At the > prompt, type 0 to record the current value of the configuration register normally 0x2102, or 0x102.

    >o
    Configuration register = 0x2102 at last boot

    Bit# Configuration register option settings:

    15 Diagnostic mode disabled.
  • Type o/r 0x2142 to tell the router to boot from flash without loading the configuration in NVRAM at the next reload.
  • Type i to have the router reboot. The router ignores the configuration in NVRAM.

  • The router runs the setup dialog, Type no or press Ctrl-C to skip the initial setup Dialog. 

  • Type enable ate the Router> prompt to go to privileged exec mode.
  • Copy the startup configuration to the running configuration by using the configure memory or copy startup-config running-config commands. Do not type configure terminal. If you use the configure terminal command, you overwrite the configuration stored in NVRAM.
  • View the configuration by typing write terminal or show running-config. View the configured line, vty and enable passwords. Any encrypted passwords need to be changed. 
  • Enter the configuration mode by typing configure terminal. Change the line of enable passwords as necessary.
  • All interfaces are in a shutdown state. Issue the no shutdown command on every interface that is to be used.
  • Type config-register 0x2102 to return the router to normal operation at the next reloads.
  • Exit configuration mode by pressing Ctrl-Z
  • Save your changes by typing write memory or copy running-config startup-config.
  • Reload the router and verify the passwords.




How to configure OSPF step by step?

OSPF short for Open Shortest Path First is a Routing Protocol used to select the best suitable route for packets with in the network. OSPF basically an open standard protocol and not relate to any particular vendor. OSPF propagate the changes to all networks more quickly as compare to RIP and IGRP protocols then only send the changed part of the routing table to the other routers with in their area. We can decrease the size of routing table by dividing a big network into logically small segment using its area feature. OSPF protocol check the availability of others routers in the network by sending Hello packets, if the other router does not respond then it is assumed to be dead router. When you used OSPF for single area configuration, its configuration method is slightly differs from the RIP and IGRP. 

There are some common OSPF configuration and Executable commands:

OSPF configuration on Router A 

In global configuration mode  

Router-A(config) # router ospf 1 (Here 1 indicate the process identification number)

Router-A(config-Router) # network 20.0.0.0 0.255.255.255 area 0 (Here 20.0.0.0 indicate the network ID and 0.225.255.255 wildcard mask with area 0)

Router-A(config-Router) # network 40.0.0.0 0.255.255.255 area 1 (Here 40.0.0.0 indicate the network ID and 0.225.255.255 wildcard mask with area 1)

OSPF configuration on Router B 

In global configuration mode  

Router-B(config) # router ospf 1 (Here 1 indicate the process identification number) 

Router-B(config-Router) # network 20.0.0.0 0.255.255.255 area 0 (Here 20.0.0.0 indicate the network ID and 0.225.255.255 wildcard mask with area 0)

Router-B(config-Router) # network 30.0.0.0 0.255.255.255 area 1 (Here 30.0.0.0 indicate the network ID and 0.225.255.255 wildcard mask with area 1) 

Now on both routers each Network will be added automatically, you can ping to Router A and Router B to check communication. You can verify this on Router-A or Router-B by using command Router# ping 40.0.0.10 (ping for Router B) and Router # ping 30.0.0.20 (ping for router A).

Router commands and configuration

Router (Router commands) working with two main ports, configuration and communication port. We manage all router setting using configuration port. Here are some useful router commands to manage router configuration.

Set Line Console Password

router>enable

router#configure terminal

router(config)#line console 0

router(config-line)#login

router(config-line)#password submask

router(config-line)#exit

router(config)#exit

Remove Console password

router>enable

router#configure terminal

router(config)#line console 0

router(config-line)#no login

router(config-line)#no password

router(config-line)#exit

router(config)#exit

Remove Secret Password

router>enable

router#configure terminal

router(config)#no enable secret

router(config)#exit

How to check Configuration Register Value

router>enable

router#show version

How to Administratively shutdown Router's Interface

router>enable

router#configure terminal

router(config)#int s0/0

router(config-if)#shutdown

To Enable Router's Serial Interface

router#configure terminal

router(config)#int s0/0

router(config-if)#no shutdown

To check Serial Interface

router>enable

router(config)#show interfaces s0/0

To set Clock rate on Router's Serial Interface

router>enable

router#configure terminal

router(config)#interface s0/0

router(config-if)#clock rate 64000

 

DTE/DCE Status

router>enable

router#show controllers s0/0

To Save Running Configuratoin

router#copy running-config startup-config

 

IOS uploading from Router to TFTP Server

router#copy flash: tftp

 

Backup Startup Configuration to TFTP

router#copy startup-config tftp

To Save Running Configuration

router#write memory

Deletion of NVRAM Configuration

router#write erase

To check NVRAM Configuration

router#show staratup-config

Citation: http://www.computerfreetips.com/Cisco_router_tips/u_show_router.html



Tuesday, June 30, 2009

Begining at Network World

I start my journey to be a CCNA this year. Here i write and make a collection of my thought about Computer Network world. wish me best of luck. :)